收到网关设备后,您需要配置网关设备并在交换机中添加相关路由配置。

配置网关设备

完成以下操作配置网关设备:
  1. 收到网关设备后,请按照SAG-1000检查配件,确认无误后将网关设备连通电源。
  2. 将智能接入网关设备1的G3端口和交换机A的G11端口相连,将其G4端口和交换机B的G12端口相连。
  3. 将PC网卡和智能接入网关设备的端口2相连,并将PC网卡IP配置为192.168.0.100/24。
  4. 打开浏览器,输入智能接入网关设备的Web配置地址。

    默认地址为https://192.168.0.1,更多信息参见登录Web配置

  5. 配置业务IP和管理口。

    本操作中业务IP设置为192.168.101.1,管理IP设置为192.168.20.1/24,下一跳设置为192.168.20.4。



    配置 说明
    业务IP 业务IP用来建立VPN隧道。
    管理口 管理口是本地Web接入的端口,默认是2号端口。
    管理IP 指定本地客户端Web接入的管理IP。
    是否隔离 选择是否将业务端口和管理端口隔离:
    • :该端口只能作为本地Web管理端口使用,不能作为业务端口使用。

      隔离方式下业务流量和管理流量互不影响,安全性更高。

    • :该端口即作为本地Web管理端口又作为业务端口使用。
    下一跳 如果选择隔离业务口和管理口,指定管理口的下一跳。
  6. 配置和交换机通信的端口:
    • 连接方式:选择使用静态路由或动态路由,本操作选择动态路由
    • 端口:单击配置信息区域的编辑选项,然后输入用来互通的端口IP并选择是否开启OSPF路由。
      本操作中选择开启OSPF路由,指定的互通端口为192.168.11.2/24和192.168.12.2/24。

  7. 配置OSPF。

    本操作选择MD5认证,RouterID使用业务IP192.168.101.1。



    配置 说明
    连接方式 选择使用静态路由或动态路由方式接入交换机。
    注意 当使用双机旁挂模式时,推荐使用动态路由方式。
    端口 单击配置信息区域的编辑选项,然后输入用来互通的端口IP并选择是否开启OSPF路由。

    端口2是默认管理端口。

    OSPF路由配置
    Area ID 区域ID。

    确保智能接入网设备1和设备2的区域ID不同,并和对端交换机设备保持一致。

    Hello_time 发送hello的时间间隔(单位秒)。

    默认值:3秒。

    Dead_time OSPF邻居失效时间(单位秒),在dead时间内没收到hello包就会断开邻居关系。

    默认值:10秒。

    认证方式 选择一种认证方式:
    • 不认证:不做认证。
    • 明文认证:输入明文密码。
    • MD5认证:采用MD5方式进行认证,输入MD5 key ID和MD5 key。
    Routerid OSPF路由器的ID,建议您直接使用业务IP。
    Area Type 区域类型默认为nssa。

配置对端交换机

根据以下配置,为设备1对端的交换机添加路由配置,此处以某品牌交换机为例,由于不同厂商交换机配置不同,详情请参考厂商设备手册:
  • 互联交换机的路由配置。
    说明 同一个智能接入网关设备运行OSPF协议接口的网络类型需要配置为p2p,否则不能正确的计算路由。
    interface GigabitEthernet 0/11
     no switchport
     ip ospf network point-to-point
     ip ospf authentication message-digest
     ip ospf message-digest-key 7 md5 1234
     ip ospf hello-interval 3
     ip ospf dead-interval 10
     ip address 192.168.11.1 255.255.255.0     智能接入网关对端交换机的端口IP
    
    interface GigabitEthernet 0/12
     no switchport
     ip ospf network point-to-point
     ip ospf authentication message-digest
     ip ospf message-digest-key 7 md5 1234
     ip ospf hello-interval 3
     ip ospf dead-interval 10
     ip address 192.168.12.1 255.255.255.0  智能接入网关对端交换机的端口IP
    						
  • 配置交换机的Loopback地址。
    说明 OSPF需要配置为NSSA区域,且自动产生默认路由发布给智能接入网关。
    interface Loopback 0
    ip address 192.168.101.3 255.255.255.255                       交换机的loopback地址
    router ospf 1
     router-id 192.168.101.3                                       交换机的routerID
     area 0
     area 1
     area 1 nssa translator always default-information-originate
     network 192.168.3.0 0.0.0.255 area 0                         本地的PC网段
     network 192.168.11.0 0.0.0.255 area 1                        交换机设备的网段
     network 192.168.12.0 0.0.0.255 area 1
     network 192.168.13.0 0.0.0.255 area 2
     network 192.168.14.0 0.0.0.255 area 2
     network 192.168.100.0 0.0.0.255 area 0                      和上联的路由器通信的网段
     network 192.168.101.3 0.0.0.0 area 0                        交换机本身的loopback地址
     default-information originate always                        默认路由发给智能接入网关