全部产品

mPaaS Inside/组件化接入方式下的环境配置

更新时间:2020-10-27 20:34:41

在进行客户端开发之前,您首先需要配置开发环境:

配置 Windows 开发环境

参考以下说明配置 Windows 开发环境:

配置 Java 8 环境

mPaaS 框架只支持 JDK 8+

  1. 下载并安装 JDK 8
  2. 配置 JAVA_HOME 环境变量,并将 JAVA_HOME 下的 bin 路径添加到 PATH 环境变量中。
  3. 正确配置后,在命令行执行 java -version 命令,您将看到 JDK 版本等信息:
    java_version_cmd.png

配置 Gradle 4.4 环境

mPaaS 框架只支持 Gradle 4.4

使用 Gradle Wrapper(推荐)

  1. 如果您的项目原先已经使用 Gradle Wrapper 进行构建,则建议在项目目录/gradle/wrapper/gradle.properties 下把版本号修改为4.4
  2. 如果您的项目没有使用 Gradle Wrapper,建议先使用全局的 Gradle(4.4)版本,然后调用 gradle wrapper --gradle-version=4.4 安装一个 gradle wrapper。完成上述步骤后,您只需要使用 ./gradlew 的形式构建,这样的方式能最小的影响您的开发环境。

使用独立 gradle

  1. 下载 Gradle 4.4.zip
  2. 解压 .zip 包,然后将解压路径配置为 GRADLE_HOME 环境变量,并将 GRADLE_HOME 下的 bin 路径添加到 PATH 环境变量中。
  3. 正确配置后,在命令行执行 gradle -v 命令,您将看到 Gradle 版本等信息:
    gradle_v_cmd.png

安装并配置 Android Studio

安装 Android Studio

最新版 mPaaS 插件仅支持 4.0 及以上版本的 Android Studio。

  • 关于 Android Studio 下载,请参见 Android Developers
  • 安装指南
  • 如果您之前使用的是低版本 Android Studio 并已经安装了 mPaaS 插件,那么在您从低版本 Android Studio 升级至 4.0 或更新版本的 Android Studio 之后,您只需要升级 mPaaS 插件至最新版本即可。详情请参见 更新 mPaaS 插件
  • 如果您需要支持 4.0 之前版本 Android Studio 的 mPaaS 插件,请在下载离线安装包后,采用离线安装形式安装。更多关于离线安装的指导说明,请参考 离线安装 mPaaS 插件

安装 Android SDK

您需要安装 API Level 为 1926 的 Android SDK:

  1. 在 Android Studio 中,通过 File > Settings 打开设置对话框。
  2. 如下图所示,在 Android SDK 对话框中,勾选 API Level 为 1926 的 SDK,然后点击 Apply 按钮进行安装:
    install_android_sdk

安装 mPaaS 插件

关于更多安装 mPaaS 插件的信息,请参见 安装 mPaaS 插件

配置 Gradle 构建工具

您需要确保工程构建时使用 Gradle Wrapper

  1. 在 Android Studio 中,通过 File > Settings 打开设置对话框。
  2. 如下图所示,在 Gradle 对话框中,勾选 Use default gradle wrapper,然后点击 Apply 按钮:
    gradle

配置 macOS 开发环境

按照以下描述配置 macOS 开发环境:

配置 Java 8 环境

mPaaS 框架只支持 JDK 8+

  1. 下载并安装 JDK 8
  2. 配置 JAVA_HOME 环境变量,并将 JAVA_HOME 下的 bin 路径添加到 PATH 环境变量中。
  3. 正确配置后,在命令行执行 java -version 命令,您将看到 JDK 版本等信息:
    java_version_cmd.png

配置 Gradle 4.4 环境

mPaaS 框架只支持 Gradle 4.4

使用 Gradle Wrapper(推荐)

  1. 如果您的项目原先已经使用 Gradle Wrapper 进行构建,则建议在项目目录/gradle/wrapper/gradle.properties 下把版本号修改为4.4
  2. 如果您的项目没有使用 Gradle Wrapper,建议先使用全局的 Gradle(4.4)版本,然后调用 gradle wrapper --gradle-version=4.4 安装一个 gradle wrapper。完成上述步骤后,您只需要使用 ./gradlew 的形式构建,这样的方式能最小的影响您的开发环境。

使用独立 gradle

  1. 下载 Gradle 4.4.zip
  2. 解压 .zip 包,然后将解压路径配置为 GRADLE_HOME 环境变量,并将 GRADLE_HOME 下的 bin 路径添加到 PATH 环境变量中。
  3. 正确配置后,在命令行执行 gradle -v 命令,您将看到 Gradle 版本等信息:
    gradle_v_cmd.png

安装并配置 Android Studio

安装 Android Studio

最新版 mPaaS 插件仅支持 4.0 及以上版本的 Android Studio。

  • 关于 Android Studio 下载,请参见 Android Developers
  • 安装指南
  • 如果您之前使用的是低版本 Android Studio 并已经安装了 mPaaS 插件,那么在您从低版本 Android Studio 升级至 4.0 或更新版本的 Android Studio 之后,您只需要升级 mPaaS 插件至最新版本即可。详情请参见 更新 mPaaS 插件
  • 如果您需要支持 4.0 之前版本 Android Studio 的 mPaaS 插件,请在下载离线安装包后,采用离线安装形式安装。更多关于离线安装的指导说明,请参考 离线安装 mPaaS 插件

安装 Android SDK

您需要安装 API Level 为 1926 的 Android SDK:

  1. 在 Android Studio 中,通过 Android Studio > Preferences 打开设置对话框。
  2. 如下图所示,在 Android SDK 对话框中,勾选 API Level 为 1926 的 SDK,然后点击 Apply 按钮进行安装:
    install_android_sdk

安装 mPaaS 插件

关于更多安装 mPaaS 插件的信息,请参见 安装 mPaaS 插件

配置 Gradle 构建工具

您需要确保工程构建时使用 Gradle Wrapper

  1. 在 Android Studio 中打开任意一个 Android 工程。
  2. 打开设置对话框。
  3. 如下图所示,在 Gradle 对话框中,勾选 Use default gradle wrapper,然后点击 Apply
    use_gradle_wrapper.png

配置 Linux 开发环境

按照以下说明配置 Linux 开发环境。
说明:Linux 操作系统版本较多,本文仅适用于 CentOS 和 Ubuntu 版本。

配置 Java 8 环境

mPaaS 框架只支持 JDK 8+

  1. 下载并安装 JDK 8
  2. 配置 JAVA_HOME 环境变量,并将 JAVA_HOME 下的 bin 路径添加到 PATH 环境变量中。
  3. 正确配置后,在命令行执行 java -version 命令,您将看到 JDK 版本等信息:
    java_version_cmd.png

配置 Gradle 4.4 环境

使用 Gradle Wrapper(推荐)

  1. 如果您的项目原先已经使用 Gradle Wrapper 进行构建,则建议在项目目录/gradle/wrapper/gradle.properties 下把版本号修改为4.4
  2. 如果您的项目没有使用 Gradle Wrapper,建议先使用全局的 Gradle(4.4)版本,然后调用 gradle wrapper --gradle-version=4.4 安装一个 gradle wrapper。完成上述步骤后,您只需要使用 ./gradlew 的形式构建,这样的方式能最小的影响您的开发环境。

使用独立 gradle

  1. 下载 Gradle 4.4.zip
  2. 解压 .zip 包,然后将解压路径配置为 GRADLE_HOME 环境变量,并将 GRADLE_HOME 下的 bin 路径添加到 PATH 环境变量中。
  3. 正确配置后,在命令行执行 gradle -v 命令,您将看到 Gradle 版本等信息:
    gradle_v_cmd.png

安装 32 位兼容库

CentOS 6、CentOS 7、Ubuntu 等 Linux 发行版默认去除 ia32-lib。所有 64 位 Linux 系统都需安装 32 位兼容库。参照 android-sdk 中的安装方法:

  1. Ubuntu:
  2. sudo apt-get install zlib1g:i386
  3. CentOS:
  4. yum install libstdc++.i686

安装并配置 Android Studio

安装 Android Studio

最新版 mPaaS 插件仅支持 4.0 及以上版本的 Android Studio。

  • 关于 Android Studio 下载,请参见 Android Developers
  • 安装指南
  • 如果您之前使用的是低版本 Android Studio 并已经安装了 mPaaS 插件,那么在您从低版本 Android Studio 升级至 4.0 或更新版本的 Android Studio 之后,您只需要升级 mPaaS 插件至最新版本即可。详情请参见 更新 mPaaS 插件
  • 如果您需要支持 4.0 之前版本 Android Studio 的 mPaaS 插件,请在下载离线安装包后,采用离线安装形式安装。更多关于离线安装的指导说明,请参考 离线安装 mPaaS 插件

安装 Android SDK

您需要安装 API Level 为 1926 的 Android SDK:

  1. 在 Android Studio 中,通过 File > Settings 打开设置对话框。
  2. 如下图所示,在 Android SDK 对话框中,勾选 API Level 为 1926 的 SDK,然后点击 Apply 按钮进行安装:
    install_android_sdk.png

安装 mPaaS 插件

关于更多安装 mPaaS 插件的信息,请参见 安装 mPaaS 插件

配置 Gradle 构建工具

您需要确保工程构建时使用 Gradle Wrapper

  1. 在 Android Studio 中打开任意一个 Android 工程。
  2. 打开设置对话框。
  3. 如下图所示,在 Gradle 对话框中,勾选 Use default gradle wrapper,然后点击 Apply 按钮:
    use_gradle_wrapper.png