本文介绍了如何安装ECS Java SDK以及阿里云核心库。

前提条件

安装ECS Java SDK必须用1.6或更高版本JDK。

背景信息

您可以自行下载aliyun-java-sdk-ecs,也可以使用Maven坐标来使用SDK。

本文示例中,客户端使用了Windows 7 64位操作系统,安装的Java使用环境为Eclipse Luna。

操作步骤

  1. 访问Maven官方下载页面(Download Apache Maven)下载对应操作系统的Maven软件。

    Checksum文件可供您校验下载文件是否正确无误。


    Maven下载页面
  2. 找到并解压Maven压缩包,将下列Maven库信息添加到conf文件夹下的settings.xml文件中。
    <repositories>
        <repository>
            <id>sonatype-nexus-staging</id>
            <name>Sonatype Nexus Staging</name>
            <url>https://oss.sonatype.org/service/local/staging/deploy/maven2/</url>
            <releases>
                <enabled>true</enabled>
            </releases>
            <snapshots>
                <enabled>true</enabled>
            <snapshots>
        </repository>
    </repositories>
  3. 打开阿里云开发者中心(https://developer.aliyun.com/tools/sdk?#/java),将阿里云的SDK存放的Maven库加入到Maven软件中。
  4. 通过以下任一方式创建Maven项目:
    • 方式一:在Eclipse中添加一个Maven项目。
      添加一个Maven项目
    • 方式二:将已有的项目转换为Maven项目。
      将已有的项目转换为Maven项目
  5. 通过以下任一方式将dependency加入Maven项目中:
    • 方式一:打开Maven项目下的pom.xml文件,添加aliyun-java-sdk-core、aliyun-java-sdk-ecs和fastjson依赖。您可以根据自身需要添加不同的依赖。
      <dependencies>
          <dependency>
              <groupId>com.aliyun</groupId>
              <artifactId>aliyun-java-sdk-core</artifactId>
              <version>4.4.3</version>
          </dependency>
          <dependency>
              <groupId>com.aliyun</groupId>
              <artifactId>aliyun-java-sdk-ecs</artifactId>
              <version>4.17.1</version>
          </dependency>
          <dependency>
              <groupId>com.alibaba</groupId>
              <artifactId>fastjson</artifactId>
              <version>1.2.60</version>
          </dependency>
      </dependencies>
    • 方式二:通过图形化界面选择性添加。
      通过图形化界面选择性添加
  6. 保存更改。

    Maven Dependencies中会自动下载并加入.jar后缀的相应Java SDK。


    Maven Dependencies