全部产品
云市场

JAVA SDK安装

更新时间:2020-02-10 14:12:35

HBase增强版支持使用HBase-1.x和HBase-2.x版本客户端进行访问。用户可以通过以下几种方式,完成JAVA SDK的安装

依赖阿里云发布的HBase客户端

您可以使用阿里云发布的HBase客户端替换您原来的HBase依赖。根据您之前依赖的HBase版本的不同,我们提供了HBase-1.x和HBase-2.x两个版本的客户端供您依赖。优先推荐使用HBase-2.x的依赖。

HBase-2.x版本

  1. <dependency>
  2. <groupId>com.aliyun.hbase</groupId>
  3. <artifactId>alihbase-client</artifactId>
  4. <version>2.0.7</version>
  5. </dependency>

HBase-1.x版本

  1. <dependency>
  2. <groupId>com.aliyun.hbase</groupId>
  3. <artifactId>alihbase-client</artifactId>
  4. <version>1.1.12</version>
  5. </dependency>

依赖HBase增强版访问插件

优先推荐依赖阿里云提供的HBase客户端来访问HBase增强版,如果您的项目无法更换之前的HBase依赖(比如您使用一个第三方库访问HBase,而第三方库里已经有HBase客户端,无法更改),可以采取再额外依赖一个阿里云提供的访问插件的方式来访问HBase增强版。增强版访问插件alihbase-connector有两个系列的版本,1.x版本对应依赖的是HBase-1.x系列的客户端,如果您的HBase客户端是1.x版本,请使用此依赖。2.x版本对应依赖的是HBase-2.x系列的客户端,如果您的HBase客户端是2.x版本,请使用此依赖。

对应HBase-1.x版本客户端的插件

  1. <dependency>
  2. <groupId>com.alibaba.hbase</groupId>
  3. <artifactId>alihbase-connector</artifactId>
  4. <version>1.0.12</version>
  5. </dependency>

对应HBase-2.x版本客户端的插件

  1. <dependency>
  2. <groupId>com.alibaba.hbase</groupId>
  3. <artifactId>alihbase-connector</artifactId>
  4. <version>2.0.12</version>
  5. </dependency>

如果您的项目无法使用maven依赖,我们还直接把alihbase-connector的jar包提供在下方,您可以直接下载后放到对应的libs目录。

  • 对应HBase-1.x版本的alihbase-connector 1.x版本的jar文件,点此下载
  • 对应HBase-2.x版本的alihbase-connector 2.x版本的jar文件,点此下载

Java API的使用和连接参数请见下一篇文档HBase Java API 访问